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Chapter 1 General Rules

The elements which precede the chapters in the Docbooks and DITA books are linked to critical
parts of the stylesheets. Therefore, none of these elements should be deleted as this will disrupt
the functioning of the stylesheets. These elements should be edited to accurately reflect the
information for the system being covered by the manual.

1.1 Spelling
FLIR Surveillance publications written in English use US, not British, spellings.

1.2 Grammar and Punctuation

1.2.1 Capital Letters
Nouns: Do not use initial capitals for words unless they are proper nouns.
Run-on headings: If text is prefixed with a run-on heading that ends in a colon, the word
following the colon starts with a capital letter.

1.2.2 Commas
Commas: Use the Oxford comma before conjunctions such as “and” or “or”. Example: Red,
blue, and green.

1.2.3 Dashes, Slashes, and Hyphens
Dashes, slashes, and hyphens are punctuation marks used to indicate a relationship between
words or phrases.

1.2.3.1 Dashes
A dash comes between words as a form of division or to indicate a range. En dashes, without a
space before and after, are used instead of “and” and “to”. Examples: 25–50, January–April.

1.2.3.2 Slashes
A slash, without a space before and after, is used to indicate a choice. Example: Imaging hot/
cold areas.
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1.2.3.3 Hyphens
Hyphens are used to join words. Use hyphens sparingly. In general, omit hyphens in words
unless they look strange without a hyphen (refer to dictionary).
Hyphenate compound adjectives occurring before nouns with the following exceptions:

• Well known adjective phrases. Example: Molded-plastic cup, but not stainless steel cup.
• Phrases with adjectives ending in “y”. Example: High-powered car, but not highly powered

car.

Hyphenate compound nouns when necessary to prevent ambiguity. Example: Plastic wire-
fastener, since “plastic wire fastener” could mean plastic-wire fastener.

1.3 Symbol Characters
The following table provides the key combinations to render symbols in a document.

Table 1-1. Symbol Character Key Combinations

Symbol Explanation Key Combination
— em dash Alt+0151
– en dash Alt+0150

™ trademark sign Alt+0153

© copyright sign Alt+0169

® registered trademark sign Alt+0174

° degree sign Alt+0176

– minus sign Alt+0150

… ellipsis sign Alt+0133

± plus/minus sign Alt+0177

1.4 Numbers
In general usage, numbers below 10 use letters, and numbers above nine use numerals.
Numbers used to express a measurement (e.g., 5 psi) will use numerals in all situations.

1.5 Menu Path Carats
When writing a menu path, e. g. Main Menu > Display > Display Preference, a space will be
placed before and after the carats (>).
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1.6 Text Element Settings
The below table provides the stylesheet settings for the various text elements in a document.
These settings are to be considered the text requirements for any FLIR Surveillance Tech Pubs
documents created in Arbortext.

Table 1-2. Text Element Settings

Element Text Indent Spacing
Font
Family

Font
Size

Bold Color Align-
ment

Indentation Before After

Main Book Title Sanserif 36 Yes Blue Centered

Book Title
(Generated Text_
ufe:
FrontMatterBlue24-
Font)

Sanserif 24 Yes Blue Centered 0.4in 0.4in

Revision Title (Title
in Front Matter)

Sanserif 24 Yes Blue Left 0.5em 0em

Chapter Sanserif 24 Yes Blue Left 0.5em 1em

Section 1.2 Sanserif 14 Yes Blue Left 1em 0.5em

Section 1.2.3 Sanserif 14 Yes Blue Left 1em 0.5em

Section 1..2.3.4 Sanserif 14 Yes Blue Left 0.75em 0.25em

Section 1.2.3.4.5 Sanserif 14 Yes Blue Left 0.5em 0.25em

Para Arial 12 No Black Justified 7pt 0pt

Warning (note
attribute)

Arial 12 Left Left 0.5in
Right 0.5in

6pt 6pt

ufe:Warning Arial 18 Yes Black
(Red text
shading)

Centered

Caution (note
attribute)

Arial 12 Left Left 0.5in
Right 0.5in

6pt 6pt

ufe:Caution Arial 18 Yes Black
(Yellow
text
shading)

Centered

Note Arial 12 Left Left 0.5in
Right 0.5in

ufe:Note Arial 18 Yes Centered 0pt 0pt

Figure Title Sanserif block-
title
prop-
erty
set

Yes Blue Centered Left 1pt
First line
–1pt

0.5em 0em
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Table 1-2. Text Element Settings (Continued)

Element Text Indent Spacing
Table Entry Arial 10 No Black Left

List Item Arial 12 No Black Justified 7pt 0pt

Header/Footer Text
(ufe:
headerfooterfor-
mat)

Arial De-
rived
from
Table
Entry

De-
rived
from
Table
Entry

Derived
from
Table
Entry

Derived
from
Table
Entry

0pt 0pt

1.7 Filenames
All filenames stored in the Arbortext Content Manager shall use underscores (_) in lieu of
spaces, commas, hyphens, etc. Hyphens may be used where they are the normal part of the
function or component (e.g. RS-422).

Table 1-3. Filename Convention
LRU_TFU_Front_View_380HD Acceptable

LRU_TFU_Front View_380HD Unacceptable

LRU, TFU, Frontview, 380HD Unacceptable

LRU_TFU_Frontview_380–HD Unacceptable

The filenames for manuals should not include the Revision letter in the filename.

1.8 Metadata Labels
Metadata labels are used to tag a file with information which can be used to locate the file. A
metadata label should not duplicate text which is already contained in the file.

General Rules



1-5

Metadata labels should be attached to each of the following:

• Book
• Bookmap
• Caution
• Chapter
• DITA Concept
• DITA Map
• DITA Reference
• DITATask
• DITATopic
• Graphic
• Note
• Warning

The metadata labels described in this document shall be used in lieu of any other variations in
spelling or usage.
Labels can be used in combination to narrow down the specificity of the file. For example, a
graphic can be tagged with a Family label, the Component ID graphics tag, and the Blending
Feature tag.

1.8.1 Metadata Family Labels
• BS (for files which apply to all BRITE Star family products)

• BSII (for BRITE Star II)
• BSDP (for BRITE Star DP)
• BSBII (for BRITE Star Block II)

• SS (for files which apply to all Star SAFIRE Series family products, excluding Star SAFIRE
380 products)

• SSIII (for Star SAFIRE III)
• SSHD (for Star SAFIRE HD)

• SS380 (for files which apply to all Star SAFIRE family products)

• 380HD (for Star SAFIRE 380–HD)
• 380HLD (for Star SAFIRE 380–HLD)
• 380THD (for TacFLIR 380–HD)
• 380THLD (for TacFLIR 380–HLD)
• 380HDC (for Star SAFIRE 380–HDc
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1.8.2 Graphics Labels
Graphics are divided into five categories:

• Component identification
• Symbology
• Demonstration (or sample)
• System menus
• Corporate (logos, etc.)

1.8.3 Feature Labels

General Rules
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1.8.4 Function Labels

1.8.5 Component Labels
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Chapter 2 Front Matter
Many of the elements in the front matter section are used to generate text throughout the
document. Caution should therefore be exercised when editing front matter material.

2.1 DocBooks

2.1.1 DocBook Title Page
The “title” element should be edited to reflect the system name.
The “subtitle” element should be edited to reflect the type of manual (Operator’s Manual,
Component Maintenance Manual, etc.).
The “titleabbrev” element should be edited to reflect the distribution of the manual as follows:

• Global Edition — Manuals which are distributed to all FLIR customers.
• US Edition — Manuals restricted to domestic customers only.
• International Edition — Manuals for FLIR’s overseas customers.

The “pubsnumber” element should be edited to reflect the correct document number and
revision level.
The “date” element should be edited to reflect the date of publication.
The “address” element should not require any changes.
The first “productname” element should be edited to reflect the correct system name.
The first “releaseinfo” element should be edited to reflect the FLIR Technology Level.
The fourth “releaseinfo” element should be edited to reflect the system and its patents. If there
are no patents, do not delete this element. Enter “Not Applicable”.
The “copyright” element should be edited to reflect the current year.
The “revhistory” element should be edited to add a new “revision” element to reflect the current
edition and the changes made to the document.

NOTE
The “revhistory” element needs to fit on one page of the document. To shorten the
Revision page, delete the “revdescription” element from the oldest revisions.

2.1.2 DocBook Revision Page
The Revision list shall be from the most current document revision back to the initial release
date information, if it all fits. If necessary, the oldest revisions should be abbreviated to just the
revision letter and release date, or deleted, to fit the Revision page onto one page.

Front Matter
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The following statement is contained within generated text elements and placed at the bottom of
the Revision page:

• FLIR® Systems Inc. maintains the highest standards of design, manufacturing, and service
for its products. We reserve the right to continually revise and improve this product. This
document describes the state of the system at the time of publication, and may not reflect the
system configuration (hardware and software) at all times in the future.

2.2 DITA Books

2.2.1 DITA Book Title Page
The “mainbooktitle” element should be edited to reflect the system name.
The “booktitlealt” element should be edited to reflect the type of manual (Operator’s Manual,
Component Maintenance Manual, etc.).
The “publisherinformation” element should not require any changes.
The “bookpartno” element should be edited to reflect the correct document number and revision
level.
The “edition” element should be edited to reflect the distribution of the manual as follows:

• Global Edition — Manuals which are distributed to all FLIR customers.
• US Edition — Manuals restricted to domestic customers only.
• International Edition — Manuals for FLIR’s overseas customers.

The “bookrights” element should be edited to reflect the date of publication.
The first “data” element should be edited to reflect the correct system name.
The second “data” element should be edited to reflect the FLIR Technology Level.
The fourth “data” element should be edited to reflect the system and its patents. If there are no
patents, do not delete this element. Enter “Not Applicable”.
The fifth “data” element should be edited to reflect the current year.

2.2.2 DITA Book Revision Page
The Revision page is a separate reference topic on the bookmap. This topic will list from the
most current document revision back to the initial release date information, if it all fits on one
page. If necessary, the oldest revisions should be abbreviated to just the revision letter and
release date, or deleted, to fit the Revision page onto one page.
The following statement is contained within generated text elements and placed at the bottom of
the Revision page:

• FLIR® Systems Inc. maintains the highest standards of design, manufacturing, and service
for its products. We reserve the right to continually revise and improve this product. This
document describes the state of the system at the time of publication, and may not reflect the
system configuration (hardware and software) at all times in the future.

Front Matter



2-3

2.3 Title Page Superscript
The means used to render the trademark symbol used in the title page will be an exception to
the use of Alt codes for rendering trademarks used elsewhere in a manual. The title page
trademark symbols will be rendered using the superscript elements.
In Docbook, the trademark symbol (™) should have “largetitle” in the role attribute for the
superscript element inside the title element.
In DITA, the trademark symbol should have “largetitle” in the outputclass attribute for the sup
element inside the mainbooktitle element.

Front Matter
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Chapter 3 Tech Pubs Arbortext Procedures
3.1 Updating The ACM Server

3.2 Graphics
This section deals with graphics management in the manuals and database.

Tech Pubs Arbortext Procedures
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3.2.1 Bulk Uploading of Graphics To The Database
Add multiple graphics to the ACM all at once as follows:

1. Move all graphics to be uploaded to a dedicated folder for that purpose. Make note of the
folder path.

2. Open Arbortext Editor and connect to the ACM (Object > Connect).
3. Open Object > Browser.
4. in the Browser, navigate to the ACM Server and select the folder to which the graphics are

to be uploaded.
5. Click the Use Selection button to set the location for the new object creation.

6. Select Tool > Preferences and check the Command Line box.

Tech Pubs Arbortext Procedures
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7. Click OK to close the Preferences dialog box.
8. In the Command line, enter import_graphic_folder(“path”)

NOTE
Path = the path of the folder containing the graphics to be uploaded; e.g.
C:\Graphics

NOTE
Use “ “ quotes to pass the Path parameter as a string

NOTE
A backslash in the path must be doubled; e.g. “C:\Graphics”, use
“C:\\Graphics”

Tech Pubs Arbortext Procedures
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3.2.2 Updating A Graphic In The Database
A graphic will occasionally need to be updated in the database, and then used in the same
locations in the manuals, under the same filename, as the older version of the graphic. Since
the older version graphic was used in older versions of the manuals, it is not possible or wise to
delete the older version graphic. This procedure explains how to replace a graphic with an
updated version of the graphic so that it appears in the correct locations in the manuals going
forward, while preserving the record of the older version.

Tech Pubs Arbortext Procedures
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Update a graphic in the database as follows:

1. Open an internet browser and navigate to Windchill.
2. Go to Navigator, then click on the Browse tab.
3. Expand Technical Publications and go to the Folders bullet item.
4. Go to the Graphic folder.
5. Click on the graphic to be updated.
6. Make note of the graphic version.

7. From the Actions drop down menu, select Check Out.
8. Click OK in the Workspace screen which opens.
9. From the Actions drop down menu, select Check In.
10. In the check in screen which opens, select Choose File and navigate to the location of the

new graphic and select the graphic file.

Tech Pubs Arbortext Procedures
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NOTE
Make sure the new graphic file name is in the identical location of the
graphic being replaced, and has the identical filename as the graphic being
replaced.

11. Click Open to choose the file.
12. Make sure the graphic filename is in the Choose File field.
13. Enter the reason the graphic is being updated in the Comments field.
14. Click OK.
15. Make sure the graphic Version has been changed to a higher version than noted above.

Tech Pubs Arbortext Procedures
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ons

3.2.3 Side-by-Side Graphics
Make a graphic side-by-side with a paragraph as follows:

1. Make sure the image element precedes the paragraph element with which it will be side-
by-side.

2. Open the image element attributes.
3. Go to the Image tab and make sure the placement field has “inline” selected.
4. Go to the Other tab and enter “sidebyside” in the outputclass field.
5. Select OK to save the change to the element attributes.

3.3 Landscape Pages
A landscape document structure is designed to start a document on an even numbered page in
the landscape format.
The landscape pages must be within self-contained topics. A topic cannot have both landscape
and portrait pages in it.
A topic which contains landscape pages must be placed in the bookmap inside a topichead
element which in turn must be inside a top level topic in a chapter. The topichead element acts
as a container for landscape page topics.

Tech Pubs Arbortext Procedures
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If there are several topics in a row which are landscape, they can all be placed inside one
topichead element.

Figure 3-1. Single Landscape Topic

Single Landscape Topic
1 Top level topic in chapter

2 topichead container

3 Landscape page topic

Figure 3-2. Sequential Landscape Topics
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Figure 3-2. Sequential Landscape Topics (continued)

Sequential Landscape Topics
1 Top level topic in chapter

2 topichead container

3 Multiple landscape page topics

A landscape topic can be a DITA topic or a DITA concept.

Tech Pubs Arbortext Procedures
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Make landscape pages in a document as follows:

1. Check out the book to be modified in Arbortext Editor with Styler.
2. Create a top level topic on the bookmap for the landscape section.
3. Place a topichead element inside the top level topic.
4. Insert the DITA concept(s) or DITA topic(s) inside the topichead container which are to be

in landscape mode.
5. Place the cursor inside the beginning of the topichead element.
6. Select the Modify Attributes function.
7. Go to the Other tab in the Modify Attributes pop-up window.
8. Enter newpage in the outputclass field.

Figure 3-3. Newpage Attribute

9. Select OK to save the change to the element attributes.
10. Check in the book.

Tech Pubs Arbortext Procedures
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11. Run a pdf of the book, and make sure the pages are landscaped.

3.4 DITA Notes, Cautions, And Warnings
Notes, Cautions, and Warnings are found in topics in the Browser Reference folder. Existing
Notes, Cautions, and Warnings are linked into a document from the relevant DITA reference
topic, much the same way a graphic is linked into a topic from the Browser Graphic folder.
Notes are in the List of Notes reference topic. Cautions are in the List of Cautions reference
topic. Warnings are in the List of Tech Pubs Warnings reference topic.
Insert an existing Note, Caution, or Warning as follows:

1. Place the cursor in the document where the Note, Caution, or Warning is to be inserted.
2. In the Browser, go to Technical Publications Reference folder and select the relevant List

topic.
3. Click on View to open the List reference topic.
4.

3.5 DITA: Addresses
Addresses are to be placed in a formal table. In the table, type the address inside a “lines”
element. If a page break occurs during the printing of an address, open the “lines” attributes and
type “address” in the outputclass field.

3.6 Baseline Documents
When a document is completed, a baseline of the document should be made to preserve a
record of the document as it stood at that time. This section describes how to save and view a
baseline document.

Tech Pubs Arbortext Procedures
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3.6.1 Save A Baseline Version of a Book
Save a baseline version of a book as follows:

1. Open an internet browser and navigate to Windchill.
2. Go to Navigator, then click on the Browse tab.
3. Expand Technical Publications and go to the Folders bullet item.
4. Go to the Book (Docbooks) or Bookmap (DITA books) folder as applicable.
5. Click on the book or bookmap name to be baselined.
6. Click on the Actions dropdown menu and select Add To > Add To Baseline.

7. In the pop-up window which opens, click on the New Baseline button.

Tech Pubs Arbortext Procedures
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8. In the second pop-up window which opens, fill in the Name and Description fields.

NOTE
Generally, the Name will be identical to the document being baselined,
followed by an underscore and the Revision letter of the document.

9. Scroll down to the Select Folder field and click on the directory symbol next to it.

Tech Pubs Arbortext Procedures
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10. In the third pop-up window which opens, click on the Up One Level icon.

11. Select the 1_Baselines folder from the list.

Tech Pubs Arbortext Procedures
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12. Click OK and the third pop-up window will close.
13. Click OK in the second pop-up window, and it will close.
14. Observe the information placed in the Name field is now in the Baseline field in the first

pop-up window.

15. In the Baseline Objects section of the first pop-up window, place a check mark in the box
for the document to be baselined.

Tech Pubs Arbortext Procedures
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16. Click on Collect Objects and observe another pop-up window opens.
17. In the new pop-up window, click on the Dependents dropdown menu and select All.

Tech Pubs Arbortext Procedures
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18. Click OK and observe the new pop-up window closes.
19. Click OK in the first pop-up window.
20. Go to the 1_Baselines folder and observe the new baseline document has been created.

Figure 3-4. Sample 1_Baselines Folder List

Tech Pubs Arbortext Procedures
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3.6.2 View A Baseline Book
This procedure describes how to view a baselined document as it appeared at the time it was
preserved.

Tech Pubs Arbortext Procedures
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View a baselined book as follows:

1. Open an internet browser and navigate to Windchill.
2. Go to Navigator, then click on the Browse tab.
3. Expand Technical Publications and go to the Folders bullet item.
4. Go to the 1_Baselines folder.
5. Click on the baseline book or bookmap to be viewed.
6. Click on the Actions dropdown menu and select Add To Workspace.

7. Use the Workspace dropdown to select an empty workspace. If there is no empty work-
space, select New.

Tech Pubs Arbortext Procedures
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8. In the pop-up window which opens, in the Name field, enter the name of the baseline man-
ual that is going to be viewed.

9. Click OK.
10. Make sure the new workspace name is in the Workspace field and click OK.

Tech Pubs Arbortext Procedures
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11. Open Arbortext.
12. If not logged in to Arbortext:

a. Select Object > Connect and log in.
b. In the Workspace field during login, use the drop down menu to select the workspace

that was just created in Windchill and then click Finish.

13. If already logged in to Arbortext:

Tech Pubs Arbortext Procedures
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a. Select Object > Change Workspace.

b. Use the drop down menu to select the workspace that was just created in Windchill and
then click OK.

14. In the Arbortext Browser, open the baseline manual in the Workspace.

Tech Pubs Arbortext Procedures



3-24

15. Expanding the Workspace will reveal all of the components of the baselined manual as
they stood at the time the baseline was created.

Tech Pubs Arbortext Procedures



3-25

Tech Pubs Arbortext Procedures



3-26

This page intentionally left blank.

Tech Pubs Arbortext Procedures



4-1

Chapter 4 Translations
4.1 Translating A Book

d t to
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4.1.1 Language Suffixes in Document Numbers
Translated manuals will be assigned a suffix number, after the document number, to indicate the
language of the manual in FLIR’s supply system. The –1 suffix is reserved for Compact Discs.
The table below is to be used to assign the proper language suffix number to the document
number:

Table 4-1. Language Suffixes

Suffix Language Code Language
-2 Spanish -21 Korean

-3 German -22 Lithuanian

-4 Turkish -23 Latvian

-5 Arabic -24 Maltese

-6 Bulgarian -25 Norwegian

-7 Catalan -26 Dutch

-8 Czech -27 Norwegian Nynorsk

-9 Danish -28 Polish

-10 Greek -29 Portuguese

-11 Estonian -30 Romanian

-12 Finnish -31 Russian

-13 French -32 Slovak

-14 Swiss German -33 Slovenian

-15 Hebrew -34 Swedish

-16 Croatian -34 Thai

-17 Hungarian -35 Chinese, simplified

-18 Icelandic -36 Chinese, Traditional

-19 Italian

-20 Japanese

Translations
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Figure 4-1. English Language Manual Document Number Example

Figure 4-2. Spanish Language Manual Document Number Example

Translations
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4.1.2 Prepare a Book For Translation
Prepare a book (DITA or Docbook) for translation as follows:

1. Create a file folder to which the book components will be exported:

a. Give the folder the same name as the book.
b. Create a sub-folder called “Files Sent” and make this the target folder below.

2. Open Arbortext and connect to the document server.
3. Open the Browser.
4. In the Browser window, highlight the book to be translated.
5. In the Browser window, go to the Object menu and select Export Compound Document.

6. In the Browse For Folder pop-up window, navigate to the “Files Sent” folder created in
Step 1.

7. Click OK.
8. After the book files have been exported, navigate to the file folder in Windows Explorer.
9. Zip the exported files and send the zip file to the translators.

Translations
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4.1.2.1 Exporting Generated Text
A stylesheet (DITA or Docbook) contains generated text which is not within the body of the book
files, but which appears in the final product. This generated text must also be translated to the
destination language the first time a book is translated to that language.
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Create an exportable generated text file for translation as follows:

1. Use the Arbortext Browser to open a book.
2. Open the stylesheet relevant to the book.
3. In the stylesheet menu, go to Tools > Language Properties.
4. Make sure the Default language is set to en (English).

5. In the Target languages section of the Language Properties, select Add.
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6. In the Add Target Language pop-up window, use the drop down menu to select the target
language and then select OK.

7. In the Document language mapping section of Language Properties, select Add.

8. In the Add Document Language Mapping pop-up window, use the drop down menu to se-
lect the target languarge and then select OK.

9. Select OK again.
10. In the stylesheet menu, select Tools > Export Generated Text.
11. Navigate to the “Files Sent” folder created in the Prepare A Book For Translation section

of this document.
12. Click OK if a warning pop-up shows up.
13. In Windows Explorer, navigate to the file destination folder and send the relevant dita-

base_style_xx.xlf file to the translators.

4.1.3 Receiving ATranslated Book
A book will come back from in the form of hundreds of individual files.
These will usually be zipped into a single file. The received files will not include any graphic files
which were sent, and so these will need to be copied from the Files Sent folder created when
preparing the book for transmission to the translators, and pasted into the folder where the
received files will reside.
The foreign language book should not be burst into Windchill. The translators maintain a
database of the foreign language documents from FLIR.
Manage the received files as follows:

1. Go to the file folder which was created in the above section which prepared the book com-
ponents for transmission to the translators.
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2. Create a sub-folder called “Files Received”
3. Create a sub-sub-folder with the filename being the date the files were received from the

translator, and make this the target folder below.
4. Unzip the file received from the translators and extract the files to the target folder.
5. Go to the related “Files Sent” folder and copy over all graphic files to the target folder.
6. Open Arbortext and connect to the document server.
7. In the Arbortext top menu line, select File > Open and navigate to the target folder.
8. The parent xml filename will match the book’s name as it appears in the Browser top level.

Open the parent file.
Figure 4-3. Finding Parent XML File

Finding Parent XML File

1 Parent XML filename

2 Browser top level book name

9. Once the bookmap is open, go to the [bookpartno] field and add the correct language suf-
fix to the document part number. Use the table in the Language Suffixes in Document
Numbers section of this chapter to find the correct suffix.
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4.1.3.1 Importing Generated Text
A translated document is not complete until the generated text file has also been translated and
imported into the document.
Import the generated text file as follows:

1. Open the relevant document.
2. Open the stylesheet relevant to the book.
3. In the stylesheet menu, go to Tools > Language Properties.
4. Make sure the Default language is set to “en (English)”.

5. In the Target languages section of the Language tab, make sure the Target languages sec-
tion has the desired language code. Here are the two-letter codes for the languages which
may be used:

Table 4-2. Two Letter Language Codes

Code Language Code Language
ar Arabic ja Japanese

bg Bulgarian ko Korean

ca Catalan lt Lithuanian
cs Czech lv Latvian

da Danish mt Maltese

de German nb Norwegian

el Greek nl Dutch
en English nn Norwegian Nynorsk
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Table 4-2. Two Letter Language Codes (Continued)

Code Language Code Language
es Spanish pl Polish

es-MX Mexican Spanish pt Portuguese

et Estonian ro Romanian

fi Finnish ru Russian

fr French sk Slovak
gsw Swiss German sl Slovenian

he Hebrew sv Swedish

hr Croatian th Thai

hu Hungarian tr Turkish

is Icelandic zh-Hans Chinese, simplified

it Italian zh-Hant Chinese, Traditional

6. If the target language is not correct:

a. Select the current target language and Delete
b. Select Add.
c. In the Add Target Language pop-up window, use the drop down menu to select the tar-

get language and then select OK.

7. In the Document language mapping section of the Language tab, make sure the target
language is listed. If the target language is not listed:
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a. Select Add.

b. In the Add Document Language Mapping pop-up window, use the drop down menu to
select the target language and then select OK.

c. Select OK again.

8. In the stylesheet menu, select Tools > Import Generated Text.
9. In Windows Explorer, navi r

t

10. Click Import.
11. Create a pdf of the document and make sure the document translation is correct and

complete.

4.1.3.2 Common Problems With Translation Documents
This section describes th ich may occur when receiving a translated
Arbortext document back
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4.1.3.2.1 Generated Text Issues
One of the most common issues seen in translated documents is much of the generated text is
in English in the foreign language translation. In particular, the words “Chapter”, “Figure”,
“Table”, “Index”, “Glossary”, and “This page intentionally left blank” will appear to be
untranslated. An example is shown below for a Spanish translation document.

Figure 4-4. Chapter, Figure, Table Not Translated

Sometimes, the footers in the document will appear to be only partially translated. In the
example below. the ITAR Export statement is still in English while the Proprietary statement is in
Spanish.

Figure 4-5. Mixed Translation of Footer

The most common cause of these problems is the failure to run a
software script which tags the translated files with the necessary language attribute.

ay to see if this is the cause is to open any random xml file
and check if the first element in the file is tagged with the language attribute. In the

example below, the highlighted portion of the graphic indicates the topic ID contains the “es”
(Span this attribute is missing, the software script was not run on the
files. .

Figure 4-6. File Language Attribute

Another common problem with generated text occurs with the statement at the bottom of the
Revision page. Unwanted line breaks occur in the statement, as shown below.
It has not been definitively determined what the source of this problem is, but it appears when
Arbortext generates the English version of the XLF file, it puts line breaks in the Revision page
statement portion of the file. These line breaks are then absorbed into the translated XLF file
which comes back from the translators. The line breaks are visible when examining the sent
XLF file, but are not visible when examining the received XLF file.
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The below graphics show what a broken Revision statement looks like, and what a correct
Revision statement should look like. Note the line breaks force most of the broken Revision
statement off the page.

Figure 4-7. Revision Statement, Broken

Figure 4-8. Revision Statement, Correct

The solution for this problem appears to be to have the line breaks removed from the English
version XLF file before translation.
Another common problem is a broken ITAR export statement in the footers. This problem is
similar to the broken Revision page statement, and the cause appears to be the same. A line
break is induced by Arbortext in the ITAR export statement when creating the XLF file that is
sent .

Figure 4-9. ITAR Export Statement, Broken

4.1.3.2.2 Miscellaneous Translation Issues
Chapter 7 of the Operators Manuals contains addresses. In DITA, these addresses are
contained in lines elements. These riage returns in them. Frequently,
when translated files come back the carriage returns have been
removed from the addresses, and the addresses then end up in the printed manual as a single
line. The graphics below show what a broken address looks like, and what the correct one looks
like.

Figure 4-10. Address, Broken

Figure 4-11. Address, Correct
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The fix for this problem is to open the relevant translated file and restore the carriage returns
(highlighted in the graphic below) in the lines element.

Figure 4-12. Address Carriage Returns (Lines Element)
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